GagA// 0n D nEt

It is currently Sun May 20, 2018 3:44 pm

All times are UTC




Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: Linux: Resolve rpm error "error: xx specifies multiple pack"
PostPosted: Fri Mar 13, 2009 4:16 am 
Offline

Joined: Wed Jul 18, 2007 1:14 am
Posts: 181
While working on a system with multiple packages and multiple updates, you will at times find it hard to remove certain package(s).

The common example in such enviroment can be:
Code:
error: xx specifies multiple pack

The following is the scenario and the resolution for the problem:
Quote:
[[email protected] ~]# rpm -e automake

Output:
Code:
error: "automake" specifies multiple packages

Check to see how many packages do you have for automake
Quote:
[[email protected] ~]# rpm -e automake

Output:
Code:
automake14-1.4p6-6
automake14-1.4p6-10

Here you may have a possibilities of different versions or same version and both are possible for certain packages. You can now remove the specific package you want or you can remove all the matching ones. The following will be solution for your problem:
Quote:
[[email protected] ~]# rpm -e --allmatches automake


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group